Fraud Engine Outage

Incident Report for Bynn Intelligence

Resolved

The issue was caused by a backend Rails upgrade that did not deploy correctly. Our engineering team has fixed the problem, and document processing is now fully operational.
We are currently monitoring system performance to ensure continued stability.

Thank you for your patience while we resolved this incident.
Posted Nov 04, 2025 - 13:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 04, 2025 - 13:08 UTC

Investigating

We are currently experiencing issues with our fraud detection engine. Our team is actively investigating the cause.
At this time, document processing is temporarily unavailable. We’re working to resolve the issue as quickly as possible and will provide updates once service is restored.
Posted Nov 04, 2025 - 12:08 UTC
This incident affected: Bynn API, Bynn core components, Global Verifications (mobile platforms), and Global Verifications (web platforms).