Temporary Issues with ID Verifications

Incident Report for Bynn Intelligence

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 13:40 UTC

Update

The issue has been identified and a fix is being implemented. Deploying fix, ETA 15-20 minutes.
Posted Feb 23, 2026 - 13:23 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 23, 2026 - 13:16 UTC

Investigating

We are currently experiencing temporary issues affecting ID verification processing.
Our engineering team is actively investigating the matter.

We will provide further updates as soon as more information becomes available.
Posted Feb 23, 2026 - 12:38 UTC
This incident affected: Bynn API, Global Verifications (mobile platforms), and Global Verifications (web platforms).