Backend processing disturbance

Incident Report for Bynn Intelligence

Resolved

This incident has been resolved.
Posted May 02, 2025 - 15:59 UTC

Update

We are continuing to investigate this issue.
Posted May 02, 2025 - 15:36 UTC

Investigating

We’re currently experiencing a processing error on our backend affecting some verifications. Our team is actively investigating the issue and working to resolve it as quickly as possible.
Posted May 02, 2025 - 15:36 UTC
This incident affected: Bynn API and Bynn core components.